Bug 11836 - SGen causes crash using CoreBluetooth
Summary: SGen causes crash using CoreBluetooth
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 6.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rodrigo Kumpera
URL:
: 11732 ()
Depends on:
Blocks:
 
Reported: 2013-04-17 17:43 UTC by Kirk Klobe
Modified: 2013-05-08 04:05 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (3.63 KB, application/x-gzip)
2013-04-17 17:43 UTC, Kirk Klobe
Details
repro solution (4.03 KB, application/x-gzip)
2013-04-24 19:52 UTC, Kirk Klobe
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kirk Klobe 2013-04-17 17:43:00 UTC
Created attachment 3828 [details]
repro project

Using the 6.3.x builds causes apps using CoreBluetooth to crash ~1-3s after initializing CBCentralManager.

Disabling SGen makes it all work. Also works fine with SGen on 6.2.x builds.

Sample project attached. Will crash on both Sim and Device. System Info:


=== Xamarin Studio ===

Version 4.0.4 (build 2)
Installation UUID: 5fd8e75b-d44a-468c-900b-9f29c4171727
Runtime:
	Mono 3.0.10 ((no/eff4cb5)
	GTK 2.24.18
	GTK# (2.12.0.0)
	Package version: 300100000

=== Apple Developer Tools ===

Xcode 4.6.2 (2067.2)
Build 4H1003

=== Xamarin.iOS ===

Version: 6.3.4.36 (Enterprise Edition)
Hash: 9eb42f8
Branch: 
Build date: 2013-11-04 10:49:08-0400

=== Xamarin.Android ===

Version: 4.7.4 (Enterprise Edition)
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
Java SDK: /usr

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 400040002
Git revision: a8bf58d398a13bcc7595f5f85adae04865a834d4
Build date: 2013-04-17 16:35:47+0000
Xamarin addins: f24db65837464cb72995ce5e84fa62fb0069724c

=== Operating System ===

Mac OS X 10.8.3
Comment 1 Mark Probst 2013-04-24 19:27:24 UTC
Could you include the solution file, please?
Comment 2 Kirk Klobe 2013-04-24 19:52:45 UTC
Created attachment 3871 [details]
repro solution
Comment 3 Rodrigo Kumpera 2013-04-25 09:51:28 UTC
I know the issue, I'm working on it.
Comment 4 Sebastien Pouliot 2013-04-25 11:00:05 UTC
*** Bug 11732 has been marked as a duplicate of this bug. ***
Comment 5 Rodrigo Kumpera 2013-04-25 18:59:33 UTC
Fixed, this will be part of the next beta release.

Thanks for the test case.
Comment 6 Nischal 2013-05-08 04:05:01 UTC
Today I have checked this attached sample on following builds:

X.S 4.0.5(build 4)
Mono 3.0.11 ((no/edc181c)
Xamarin.iOS 6.3.5.40

And application does not crash in both the case when SGen is enabled and when SGen is disabled and application prompts us to setting Bluetooth ON. When we click on Settings and make Bluetooth ON the, nothing happens.

Please close this issue if all the steps are correct which I have followed.