Bug 1177 - SqlMetalExecException from Generate Linq Class
Summary: SqlMetalExecException from Generate Linq Class
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Database ()
Version: 2.6
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-02 07:29 UTC by Dale E. Moore
Modified: 2014-02-17 14:34 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Dale E. Moore 2011-10-02 07:29:55 UTC
Platform Ubuntu 11.10 beta.
MonoDevelop Build date: 2011-09-22 12:46:54+0000
Here's how I got to this bug. I created an ASP.NET MVC Project, Added a PostgreSQL database connection then Tools, Database, Generate Linq Class (or Solution, Project, Right-mouse-click, Tools, Generate Linq Class.)

Following these insctrutions http://monodevelop.com/Documentation/Linq I picked my database connection (which was working OK to read the DB) accepted all defaults and received:

MonoDevelop
Cannot create Linq Class.
MonoDevelop.Database.Sql.SqlMetalExecException: sqlmetal: Object reference not set to an instance of an object
Comment 1 Lluis Sanchez 2014-02-17 14:34:46 UTC
That's not supported anymore.