Bug 11625 - MTDJsonDemo does not load from url successfully
Summary: MTDJsonDemo does not load from url successfully
Status: VERIFIED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 6.3.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: 6.4 (async)
Assignee: Mike Bluestein
URL:
Depends on:
Blocks:
 
Reported: 2013-04-05 16:56 UTC by PJ
Modified: 2013-07-11 06:59 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description PJ 2013-04-05 16:56:18 UTC
Heyo, when you use MTDJsonExample, the load from URL option just results in an error message saying 'Unable to download data'

Here's the code:

AppDelegate.cs

_rootElement = new RootElement ("Json Example"){
                new Section ("Demo Json"){
                    (Element)JsonElement.FromFile ("sample.json"),
                    (Element)new JsonElement ("Load from url", "http://localhost/sample.json")
                },
				new Section ("Tasks Sample")
            };

In particular, (Element)new JsonElement ("Load from url", "http://localhost/sample.json") is the broken call. 


Reported against:
XS 4.0.3 (13)
MT 6.3.3.2
Xcode 4.6

Checked back to:
MonoDevelop 3.1.1
MT 6.0.10
Xcode 4.5

And the behavior was the same. Was this ever working? If so, what's the proper way to structure the url/call/file structure?
Comment 3 PJ 2013-06-25 13:21:40 UTC
PEBCAK, danke :D