Bug 11585 - scrolling thru a picker control error
Summary: scrolling thru a picker control error
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 6.4 (async)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-04-04 10:20 UTC by Mike James
Modified: 2013-07-09 04:46 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
User code (13.82 KB, text/plain)
2013-04-04 10:20 UTC, Mike James
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Mike James 2013-04-04 10:20:16 UTC
Created attachment 3749 [details]
User code

Custer has subclassed an ActionSheet and is getting the following error.

at (wrapper managed-to-native) MonoTouch.UIKit.UIApplication.UIApplicationMain (int,string[],intptr,intptr) <IL 0x0009f, 0xffffffff>
at MonoTouch.UIKit.UIApplication.Main (string[],string,string) [0x0004c] in /Developer/MonoTouch/Source/monotouch/src/UIKit/UIApplication.cs:38
at AllMedsMobile.Application.Main (string[]) [0x00000] in /Users/Macdev/Projects/Main.cs:92
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <IL 0x00050, 0xffffffff>

Native stacktrace:

0 AllMedsMobile 0x0007a9ec mono_handle_native_sigsegv + 284
1 AllMedsMobile 0x000048e8 mono_sigsegv_signal_handler + 248
2 libsystem_c.dylib 0x981618cb _sigtramp + 43
3 ??? 0xffffffff 0x0 + 4294967295
4 UIKit 0x009848b8 -[UIApplication sendAction:toTarget:fromSender:forEvent:] + 61
5 UIKit 0x00a45671 -[UIControl sendAction:to:forEvent:] + 66
6 UIKit 0x00a45bcf -[UIControl(Internal) _sendActionsForEvents:withEvent:] + 578
7 UIKit 0x00a44d38 -[UIControl touchesEnded:withEvent:] + 546
8 UIKit 0x009b433f -[UIWindow _sendTouchesForEvent:] + 846
9 UIKit 0x009b4552 -[UIWindow sendEvent:] + 273
10 UIKit 0x009923aa -[UIApplication sendEvent:] + 436
11 UIKit 0x00983cf8 _UIApplicationHandleEvent + 9874
12 GraphicsServices 0x02c2bdf9 _PurpleEventCallback + 339
13 GraphicsServices 0x02c2bad0 PurpleEventCallback + 46
14 CoreFoundation 0x01ec7bf5 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 53
15 CoreFoundation 0x01ec7962 __CFRunLoopDoSource1 + 146
16 CoreFoundation 0x01ef8bb6 __CFRunLoopRun + 2118
17 CoreFoundation 0x01ef7f44 CFRunLoopRunSpecific + 276
18 CoreFoundation 0x01ef7e1b CFRunLoopRunInMode + 123
19 GraphicsServices 0x02c2a7e3 GSEventRunModal + 88
20 GraphicsServices 0x02c2a668 GSEventRun + 104
21 UIKit 0x0098165c UIApplicationMain + 1211
22 ??? 0x0c794cad 0x0 + 209276077
23 ??? 0x0c792970 0x0 + 209267056
24 ??? 0x0c792348 0x0 + 209265480
25 ??? 0x0c7926ae 0x0 + 209266350
26 AllMedsMobile 0x00008c32 mono_jit_runtime_invoke + 722
27 AllMedsMobile 0x001519fe mono_runtime_invoke + 126
28 AllMedsMobile 0x00155d24 mono_runtime_exec_main + 420
29 AllMedsMobile 0x00156095 mono_runtime_run_main + 725
30 AllMedsMobile 0x00063b25 mono_jit_exec + 149
31 AllMedsMobile 0x001f5304 main + 1988
32 AllMedsMobile 0x000025a5 start + 53

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-04-08 18:20:11 UTC
I don't see anything immediately wrong with the provided code, so can you please attach a complete test project I can use to reproduce and diagnose it?
Comment 3 PJ 2013-07-09 04:46:16 UTC
Marking this one as RESOLVED, NO RESPONSE for now. Please feel free to re-open
if the customer still reports. If you do, please add full version info and, if
possible, some steps to reproduce or a compile-able test project.