Bug 11564 - NotImplementedException in debugger output
Summary: NotImplementedException in debugger output
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-04-03 18:33 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-04-05 12:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2013-04-03 18:33:24 UTC
Mono master/caf5fc0

Thread started: Message dispatcher
System.NotImplementedException: The requested feature is not implemented.
  at Mono.Debugger.Soft.CustomAttributeDataMirror.Create (Mono.Debugger.Soft.VirtualMachine vm, Mono.Debugger.Soft.CattrInfo[] info) [0x0019e] in /Users/michael/Mono/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/CustomAttributeDataMirror.cs:140 
  at Mono.Debugger.Soft.FieldInfoMirror.GetCAttrs (Mono.Debugger.Soft.TypeMirror type, Boolean inherit) [0x00064] in /Users/michael/Mono/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/FieldInfoMirror.cs:171 
  at Mono.Debugger.Soft.FieldInfoMirror.GetCustomAttributes (Boolean inherit) [0x00001] in /Users/michael/Mono/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/FieldInfoMirror.cs:137 
  at Mono.Debugging.Soft.SoftDebuggerAdaptor.OnGetTypeDisplayData (Mono.Debugging.Evaluation.EvaluationContext gctx, System.Object type) [0x00107] in /Users/michael/Mono/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:1130
Comment 1 Zoltan Varga 2013-04-05 12:13:45 UTC
How can I reproduce this ?
Comment 2 Zoltan Varga 2013-04-05 12:35:37 UTC
Fixed in master/2.10.