Bug 11558 - Configure error blocks install
Summary: Configure error blocks install
Status: RESOLVED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Deployment ()
Version: 3.0.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-04-03 13:46 UTC by Bruce Davidson
Modified: 2013-04-04 06:42 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Bruce Davidson 2013-04-03 13:46:29 UTC
I'm on ubuntu 12.04. I installed mono develop from software settings, but quickly realized that it was not the version on the monodevelop,com website. So I uninstalled that and I've installed mono runtime 2.11.3 using this method:

http://www.integratedwebsystems.com/2012/04/install-mono-2-11/

That worked ok, and I am able to compile and run c# programs using gedit and command line.

HOWEVER - I am not able to install monodevelop from the git clone - 

bruce@barsoom:~/Applications/monodevelop$ ./configure

Configuring package: main
-------------------------
Configuration options: 
Running aclocal  ...
Running automake --foreign  ...
Running autoconf ...
Running ./configure --enable-maintainer-mode --enable-compile-warnings --prefix=/usr/local ...
configure: WARNING: unrecognized options: --enable-compile-warnings
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for mono... /opt/mono-2.11/bin/mono
checking for gmcs... /opt/mono-2.11/bin/gmcs
checking for pkg-config... /usr/bin/pkg-config
configure: error: You need mono 2.10.9 or newer

As you can see, I do have 2.10.9 or newer installed:

bruce@barsoom:~/Applications/monodevelop$ mono -V
Mono JIT compiler version 2.11.3 (tarball Mon Apr  1 22:54:39 PDT 2013)
Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  x86
	Disabled:      none
	Misc:          softdebug 
	LLVM:          supported, not enabled.
	GC:            Included Boehm (with typed GC and Parallel Mark)
bruce@barsoom:~/Applications/monodevelop$ 

Thanks,
Bruce
Comment 1 Lluis Sanchez 2013-04-04 06:42:09 UTC
You probably need to install development packages for Mono. That's what the configuration script can't find. In any case, this is not a bug.