Bug 11555 - Unable to open Layouts in Visual Studio 2010 & 2012
Summary: Unable to open Layouts in Visual Studio 2010 & 2012
Status: RESOLVED DUPLICATE of bug 11742
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.8.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-04-03 12:39 UTC by Allie Miller
Modified: 2013-05-01 10:43 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Bug image (31.97 KB, image/png)
2013-04-03 12:39 UTC, Allie Miller
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 11742

Description Allie Miller 2013-04-03 12:39:17 UTC
Created attachment 3735 [details]
Bug image

Connection to layout renderer failed
Please close and open the file again

Deleting Entitlements file does not help.

Output below:
Entering Mono.Android.VisualStudio.MonoAndroidDesignerFactory
CreateEditorInstance()
System.Exception: Java process failed to start
at Xamarin.AndroidDesigner.JavaProcessConnection.DoConnect()
'devenv.exe' (Managed (v4.0.30319)): Loaded
'C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Accessibility\v4.0_4.0.0.0__b03f5f7f11d50a3a\Accessibility.dll'
The thread '<No Name>' (0x2100) has exited with code 0 (0x0).
Comment 2 Pavel 2013-04-22 10:51:54 UTC
Same bug here. java AndroidDesigner failed to load after switching to alpha in VS2012 with message "Connection to the layout renderer failed". So no designer availible at all (even axml part). 

Workaround: i replaced AndroidDesigner.jar from VS2012 extension folder to Xamarin Studio AndroidDesigner.jar.
Comment 3 PJ 2013-05-01 10:43:18 UTC

*** This bug has been marked as a duplicate of bug 11742 ***