Bug 11539 - xbuild exits with 0 if last compiled project was successfully compiled
Summary: xbuild exits with 0 if last compiled project was successfully compiled
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-04-03 05:56 UTC by mono
Modified: 2014-02-08 04:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (6.42 KB, application/zip)
2014-02-08 04:01 UTC, Antonius Riha
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 11539 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description mono 2013-04-03 05:56:08 UTC
Steps to reproduce:

1. create solution A
2. create project B
3. create project C
4. add gibberish to one of project B's files (or anything that is an error)
5. run "xbuild A.sln && echo success"
6. observe "success" as last line in the console even though there were errors in the build
7. remove gibberish from project B, add gibberish to project C
8. repeat 5.
9. observe no "success" message
Comment 1 Matthias Mailänder 2013-10-12 05:15:11 UTC
It seems to exit with 0 no matter what https://travis-ci.org/OpenRA/OpenRA/builds/12171693#L1532 which makes it pretty useless for continuous integration.
Comment 2 Antonius Riha 2014-02-08 02:53:51 UTC
This doesn't seem to be an issue with mono 3.2.6 anymore.
Comment 3 Antonius Riha 2014-02-08 04:01:29 UTC
Created attachment 6006 [details]
Test case