Bug 11434 - Global search list shows "no results" with trailing colon
Summary: Global search list shows "no results" with trailing colon
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-03-26 18:00 UTC by Mikayla Hutchinson [MSFT]
Modified: 2013-03-27 05:14 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2013-03-26 18:00:04 UTC
If I'm trying to go to a line in the global search, when I type a trailing colon, the list shows "no results". The results only reappear when I type a number. This is a bit confusing.

http://screencast.com/t/AVu2X1gxUL
Comment 1 Mikayla Hutchinson [MSFT] 2013-03-26 18:10:59 UTC
I would suggest we continue showing the matched file in this case, or perhaps a hint that the user can enter a line,col.
Comment 2 Mike Krüger 2013-03-27 05:14:36 UTC
fixed with taking semantics into account when parsing the search string :)