Bug 11347 - [MTVS] The sample PokerNightVoting throws exception and does not launch successfully on the device.
Summary: [MTVS] The sample PokerNightVoting throws exception and does not launch succe...
Status: VERIFIED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 1.1.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2013-03-22 06:19 UTC by Jatin
Modified: 2013-04-02 09:07 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Comment 1 Marek Habersack 2013-03-22 06:29:15 UTC
Jatin, can you attach the log which contains the exception you mention? It's not in either of the logs you point to. Also, does it happen when running on device or when debugging?
Comment 2 Saurabh 2013-03-25 07:48:23 UTC
Today We have checked this issue with following builds:

VS 2012/2010
MTVS 1.1.194

Devices info:
iPhone4
Version 5.1
iPhone4s
Version 6.0.1

We observed that application deployed to device(5.1) but does not launch automatically. However, on Devices having version 6.0 and above application deployed and launched successfully.

https://gist.github.com/saurabh360/2310fdea7f438ed79fbe
https://gist.github.com/saurabh360/c81f64f2e6e26caa0132
Comment 3 Marek Habersack 2013-03-25 08:14:45 UTC
Looking at the sample's Info.plist it turns out the sample is an iOS 6 one. Considering Comment 2 I'm closing this report as invalid.
Comment 4 PJ 2013-03-25 10:04:03 UTC
> We observed that application deployed to device(5.1) but does not launch
automatically.

Are you saying you're allowed to try to deploy to an iOS 5 device? We shouldn't let people do that if the app is set to iOS 6 minimum...
Comment 5 Marek Habersack 2013-03-25 10:14:31 UTC
PJ, agreed, but it's a different bug. The original issue here doesn't exit - the application is an iOS6 one and it works fine on iOS 6 simulator, as per comment 2. This is the reason I closed this bug as invalid. A separate bug should be filed for the invalid deployment target issue.
Comment 6 PJ 2013-03-25 13:40:17 UTC
Ok, that's probably covered by 11345.
Comment 7 Saurabh 2013-04-02 09:07:54 UTC
Today I have checked this issue with following builds:

VS 2012/2010
MTVS 1.1.196
MT 6.2.2.7

Now when we debug/run the application on iOS 5.1 devices it is giving proper error and application does not deploy to device.
https://gist.github.com/atin360/26dd7f71ad275029b139

Changing the status to Verified.