Bug 1134 - Visually corrupted text when changing line
Summary: Visually corrupted text when changing line
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
: 1167 ()
Depends on:
Blocks:
 
Reported: 2011-09-29 08:47 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2011-10-04 08:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2011-09-29 08:47:36 UTC
Impossible to explain properly, see screencast below. The only thing I did in the screenshot was to press the up or down keys, nothing else.

It happens randomly, no idea what causes it. It's fixed by closing the file and reopening it.

http://screencast.com/t/WnPoe7JMr
Comment 1 Mike Krüger 2011-09-30 00:29:39 UTC
It's a bug in the height calculation, do you have a file where that happens frequently ?

Are you using the folding feature (fold/unfold much) ?
Comment 2 Mike Krüger 2011-09-30 01:04:52 UTC
Did you have message bubbles in that file ?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2011-09-30 05:49:52 UTC
It happens very once in a while, so I can't say if the file has to be special for it to happen.

I do use the folding feature once in a while, but I'm not sure if I was in this file at the time.

Next time it happens I'll get more information about it.
Comment 4 Mike Krüger 2011-09-30 05:58:53 UTC
y I could need the info about did you fold/unfold manually and/or error bubbles in that file.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2011-09-30 18:23:53 UTC
Bug 1168 looks like the same issue, and it looks like it is a code folding problem there.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2011-09-30 18:24:34 UTC
Bug 1167, not 1168.
Comment 7 Alan McGovern 2011-09-30 18:24:42 UTC
*** Bug 1167 has been marked as a duplicate of this bug. ***
Comment 8 Alan McGovern 2011-09-30 18:25:32 UTC
See this screencast too. http://screencast.com/t/ZX0igwqLobVw

In this case i definitely had no error bubbles. I just had folding.
Comment 9 Mike Krüger 2011-10-04 08:32:15 UTC
fixed.