Bug 1133 - DataBase error dialog shows up beneath the active window
Summary: DataBase error dialog shows up beneath the active window
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Database ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-29 08:36 UTC by Alan McGovern
Modified: 2016-12-14 18:57 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (254.60 KB, image/png)
2011-09-29 08:36 UTC, Alan McGovern
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Alan McGovern 2011-09-29 08:36:49 UTC
Created attachment 532 [details]
screenshot

I didn't fill in all the information and tried clicking 'ok' and the error dialog showed up beneath the create database dialog.
Comment 1 Alan McGovern 2011-09-29 08:38:08 UTC
Also the 'Create Database' screen as found when you click on: "Tools -> Database -> Create Database -> Sql Database" should be a modal dialog so it does not get hidden behind the MonoDevelop main window.
Comment 2 Alan McGovern 2011-09-29 08:39:16 UTC
Sorry, that first screenshot didn't take right. Here's a better one:  http://screencast.com/t/vWjVHqtD
Comment 3 Mikayla Hutchinson [MSFT] 2011-09-29 09:21:34 UTC
Sounds like the code that's showing the window isn't setting its parent correctly.

In general, all dialogs should be initially hidden, and should not be Run directly. Instead, they should be shown and run using MessageService.RunCustomDialog. It ensures that the dialog is positioned correctly before showing it, and if the dialog doesn't have a parent specified, it parents the dialog onto the topmost modal window. It then returns the GTK response value.

There's also the confusingly-named method MessageService.ShowCustomDialog. It's identical to MessageService.RunCustomDialog, except that it destroys the dialog after running it. Use this one if you don't need to retrieve values from widgets before destroying the dialog.
Comment 4 Greg Munn 2016-12-14 18:57:24 UTC
Tools | Create Database no longer exists. Closing.