Bug 11301 - Default Syntax Coloring does not work
Summary: Default Syntax Coloring does not work
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.1
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-03-20 14:45 UTC by Allie Miller
Modified: 2013-03-20 15:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Allie Miller 2013-03-20 14:45:22 UTC
Pretty often when I open a file, the syntax highlighting isn't applied, and then I have to re-open it for it to apply.

It works 95% of the time, but the other 5% of the time, it doesn't work at all.

MonoDevelop: 4.0.2
Runtime: Mono 2.10.12 (mono-2-10/c9b270d)
Operating System: Mac OSX (Unix 11.4.2.0)
Distributor: Xamarin
=== Xamarin Studio ===

Version 4.0.2 (build 18)
Installation UUID: 797e29c0-dcda-4dca-a8bc-45c5f0799f58
Runtime:
Mono 2.10.12 (mono-2-10/c9b270d)
GTK 2.24.16
GTK# (2.12.0.0)
Package version: 210120000

=== Apple Developer Tools ===

Xcode 4.6 (2066)
Build 4H127

=== Xamarin.Android ===

Version: 4.6.0 (Business Edition)
Android SDK: /usr/Local/Cellar/android-sdk/r17
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
3.2 (API level 13)
4.0 (API level 14)
4.0.3 (API level 15)
4.1 (API level 16)
4.2 (API level 17)
Java SDK: /usr

=== Xamarin.iOS ===

Version: 6.2.1.199 (Business Edition)
Hash: 75565c0
Branch: 
Build date: 2013-08-03 13:37:04-0500

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Build Information ===

Release ID: 400020018
Git revision: 2be11af94af70712cf550d12870275274b1ad399
Build date: 2013-03-08 07:22:12+0000
Xamarin addins: 11683a6440b38fa350cbe4d820f5cc6fee091295

=== Operating System ===

Mac OS X 10.7.5
Darwin raulagraits-MacBook-Pro.local 11.4.2 Darwin Kernel Version 11.4.2
Thu Aug 23 16:25:48 PDT 2012
root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64
Comment 1 Mike Krüger 2013-03-20 15:13:01 UTC
Which file type was it ?

I tend to close the bug - 4.0.2 has a better engine for that.
Comment 3 Mike Krüger 2013-03-20 15:34:27 UTC
Should work in the 4.0.2 line. 

(Btw. but I never had this with 4.0.1)