Bug 1124 - monodevelop refused to quit
Summary: monodevelop refused to quit
Status: RESOLVED DUPLICATE of bug 5647
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.8 beta 3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Alan McGovern
URL:
Depends on:
Blocks:
 
Reported: 2011-09-28 21:34 UTC by Chris Toshok
Modified: 2012-10-24 19:22 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 5647

Description Chris Toshok 2011-09-28 21:34:39 UTC
I had closed the iphone simulator after running my app.  monodevelop didn't seem to register that the app had stopped running (it has definitely stopped running, according to ps...)

I tried re-running the app and MD popped up a dialog that said "the app is presently running, would you like to stop it?"  I clicked yes, but no change (and no app started.)

I hit Cmd-q at that point, and MD asked if I wanted to close the project, to which I clicked Close Project.  All pads went away and I'm left with an empty monodevelop window.

I hit Cmd-q again and got an exception dialog (the app is still running):

Error while executing command: Quit.

Details:

System.Exception: There is no logger registered with the name 'MonoDevelop.Ide.Gui.Pads.InternalLogPad'
  at MonoDevelop.Core.LoggingService.RemoveLogger (System.String name) [0x0002f] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/LoggingService.cs:127 
  at MonoDevelop.Ide.Gui.Pads.InternalLogPad.Dispose () [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui.Pads/InternalLogPad.cs:295 
  at MonoDevelop.Ide.Gui.DefaultWorkbench.OnClosed (System.EventArgs e) [0x0009f] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/DefaultWorkbench.cs:651 
  at MonoDevelop.Ide.Gui.DefaultWorkbench.Close () [0x000b3] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/DefaultWorkbench.cs:686 
  at MonoDevelop.Ide.Gui.Workbench.Close () [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Gui/Workbench.cs:128 
  at MonoDevelop.Ide.IdeApp.Exit () [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide/Ide.cs:393 
  at MonoDevelop.Ide.Commands.ExitHandler.Run () [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Commands/FileCommands.cs:372 
  at MonoDevelop.Components.Commands.CommandHandler.Run (System.Object dataItem) [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandHandler.cs:61 
  at MonoDevelop.Components.Commands.CommandHandler.InternalRun (System.Object dataItem) [0x00000] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandHandler.cs:42 
  at MonoDevelop.Components.Commands.CommandManager.DefaultDispatchCommand (MonoDevelop.Components.Commands.ActionCommand cmd, MonoDevelop.Components.Commands.CommandInfo info, System.Object dataItem, System.Object target, CommandSource source) [0x00076] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:649 
  at MonoDevelop.Components.Commands.CommandManager.DispatchCommand (System.Object commandId, System.Object dataItem, System.Object initialTarget, CommandSource source) [0x002d1] in /private/tmp/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Components.Commands/CommandManager.cs:619
Comment 1 Jeffrey Stedfast 2012-10-24 19:22:53 UTC

*** This bug has been marked as a duplicate of bug 5647 ***