Bug 11233 - No mcs compiler without net 4.5 (Mono release tarball 3.0.6 and 3.0.7)
Summary: No mcs compiler without net 4.5 (Mono release tarball 3.0.6 and 3.0.7)
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-03-18 15:03 UTC by ttodorov
Modified: 2013-03-20 06:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description ttodorov 2013-03-18 15:03:53 UTC
I tried to compile mono with only net 2.0, 3.5 and 4.0.  My configure call was:

./configure --prefix=/opt/mono --with-xen_opt=no --with-profile4_5=no --with-mcs_docs=no

After make and make install, trying to compile anything fails because mcs is not installed.  I had to fix some (all) paths in the /opt/mono/bin folder to point to /opt/mono/lib/mono/4.0 folder instead of the 4.5 folder first (which is a bug in its own right anyway), but even with that nothing compiles without mcs.

Isn't it possible to install mono without net 4.5 at all?

PS. System is Ubuntu 12.10 64bit server.
Comment 1 Marek Safar 2013-03-18 16:19:55 UTC
4.0/4.5 is the default framework version and mcs is developed for 4.0/4.5. It won't run on 2.0 version
Comment 2 ttodorov 2013-03-18 17:11:53 UTC
I am sorry, but this is a non-answer.  If you notice I explicitly mentioned 4.0 (as in fix shell scripts for use with 4.0).  Besides that, I only specified --with-profile4_5=no.  The configure help states --with_profile2 and --with-profile4 as yes by default.  So in my build configured as shown in the comment above, I actually get 2.0, 3.5, and 4.0.  This is also what I have as folders under /opt/mono/lib/mono.  Only I cannot compile anything, because there is no compiler.
Comment 3 Marek Safar 2013-03-20 06:34:55 UTC
Sorry, I misread the configuration options. It should be fixed in master