Bug 11200 - Test result does not open
Summary: Test result does not open
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit ()
Version: 4.0
Hardware: PC Linux
: --- normal
Target Milestone: 4.2.3 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-03-16 08:33 UTC by Matt
Modified: 2014-02-04 09:36 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Matt 2013-03-16 08:33:36 UTC
Description of Problem:

In the test result pane, failed test result does not open. Clicking the small triangle does not open the test result.

Steps to reproduce the problem:
1. This may be only particular tests. 
2. 


Actual Results:
Clicking the small triangle does not open the test result.

Expected Results:
Clicking the small triangle does open the test result.

How often does this happen? 
For this test, always. FWIW, the test fails checking the Min of an IEnumerable that is empty. 


Additional Information:
Comment 1 Mike Krüger 2013-03-16 11:24:28 UTC
Can you give me the failing test ?
Comment 2 Matt 2013-03-16 12:17:45 UTC
Mike,

Sorry no. It is part of a proprietary application. I'm happy to attempt to debug it, if I could get some guidance on what to look for. I assume I would run MD in debug mode. Beyond that, any pointers?

Matt
Comment 3 Mike Krüger 2013-03-17 03:06:18 UTC
You have the test - is it possible to do a test that does something like the one that fails with .NET classes ?

Other than that it's somewhere in our unit test addin - I would need to dig through that as well :/
Comment 4 Matt 2013-03-18 07:18:25 UTC
I'll see about generating a test outside of my particular code. One lead though, I notice that when I try to break on Nunit exceptions (Run - Exceptions dialog) none of the Nunit stuff is there. I am pretty sure it used to be. Thanks for your attention on this, 

Matt
Comment 5 Mike Krüger 2013-03-18 07:26:46 UTC
np - I think I need to work a bit on the unit test addin - the IDE is a huge project - I always wanted to improve the unit test backend.
Comment 6 Mike Krüger 2013-09-16 05:18:47 UTC
Should work in newer mono/monodevelop versions (I suspect it was a gtk tree view bug which got fixed)
Comment 7 narayanp 2014-02-04 09:36:35 UTC
I have checked this issue with following builds:

All Windows
X.S 4.2.3(build 54)
Mono 3.2.6

I am successfully able to open failed result in Test Result window. This is the screencast for the same: http://screencast.com/t/XC7kptbabzK