Bug 11154 - VS Ultimate 2012 hangs when defining breakpoints in Android code-behind
Summary: VS Ultimate 2012 hangs when defining breakpoints in Android code-behind
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: vsx
URL:
Depends on:
Blocks:
 
Reported: 2013-03-14 10:00 UTC by Lucian POPESCU
Modified: 2015-11-03 14:08 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attachment is in french, sorry. (79.80 KB, image/jpeg)
2013-03-14 10:00 UTC, Lucian POPESCU
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Lucian POPESCU 2013-03-14 10:00:14 UTC
Created attachment 3616 [details]
Attachment is in french, sorry.

Hi, 
thank you all for the great work and effort put into the development of the framework.

I have an older issue with VS Pro/Ultimate 2012 and Mono Android, any version, that I haven't reported, until now.
Very often, when I try to debug a solution that has breakpoints defined in the code-behind in Android (on a button click, for example), I have two situations: 

I. VS hangs after outputing "copying application to device ..." and the Android emulator suggests I force the shutdown of the application (waiting for the app to respond takes too long). Afterwards, the cursor of the mouse is stuck on the progress ring, I can't click in VS or do anything but end VS process in task manager and reopen it.

II. Debugger doesn't stop on breakpoints.

Can you investigate, please? 

Thank you, waiting for a resolution,
Lucian POPESCU
Comment 1 Joaquin Jares 2015-11-03 14:08:24 UTC
This looks like a deploy issue, and the way deploy works completely changed for Android in the latest alpha. I'm marking this issue as fixed for internal verification, please reopen if this is still an issue.