Bug 11147 - The specified path is not of a legal form(empty)
Summary: The specified path is not of a legal form(empty)
Status: RESOLVED DUPLICATE of bug 10783
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: mmp ()
Version: 1.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2013-03-14 01:49 UTC by Rob LeJeune
Modified: 2013-03-14 08:06 UTC (History)
0 users

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 10783

Description Rob LeJeune 2013-03-14 01:49:54 UTC
I am unable to build the Release build of my application. The error log dump is below:


Merging Mono Runtime into app bundle
/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/usr/bin/mmp "-minos=10.6" --sdkroot "/Applications/Xcode.app/Contents/Developer" -o "/Users/robleylejeune/Projects/MacToolbarXam/MacToolbarXam/bin/Release" -n "MacToolbarXam" --profile "4.0" -a "/Library/Frameworks/Mono.framework/Versions/2.10.11/lib/mono/4.0/System.dll" -a "/Library/Frameworks/Mono.framework/Versions/2.10.11/lib/mono/4.0/System.Xml.dll" -a "/Library/Frameworks/Mono.framework/Versions/2.10.11/lib/mono/4.0/System.Core.dll" -a "/Library/Frameworks/Mono.framework/Versions/2.10.11/lib/mono/4.0/System.Xml.Linq.dll" -a "/Library/Frameworks/Mono.framework/Versions/2.10.11/lib/mono/4.0/System.Drawing.dll" -a "/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/usr/lib/mono/XamMac.dll" "/Users/robleylejeune/Projects/MacToolbarXam/MacToolbarXam/bin/Release/MacToolbarXam.exe"
Process exited with code 127, command:
pkg-config --variable=prefix mono-2
error MM0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.ArgumentException: The specified path is not of a legal form (empty).
  at System.IO.Path.InsecureGetFullPath (System.String path) [0x00000] in <filename unknown>:0 
  at System.IO.Path.GetFullPath (System.String path) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.Driver.get_MonoDirectory () [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.Driver.Pack (IList`1 unprocessed) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.Driver.Main2 (System.String[] args) [0x00000] in <filename unknown>:0 
  at MonoMac.Bundler.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 
mmp exited with code 1
Comment 1 Sebastien Pouliot 2013-03-14 08:06:41 UTC
The latest Mono releases removed the /usr/bin/pkg-config symlink. Xamarin.Mac 1.2 (in the beta channel now, soon to be promoted to stable) has a fix for this.

A workaround, if updating is not possible at the moment, si to re-create the symlink. See bug #10783 for details.

*** This bug has been marked as a duplicate of bug 10783 ***