Bug 1107 - Image files added in the directory from local system is not displaying under the MonoDev application.
Summary: Image files added in the directory from local system is not displaying under ...
Status: CLOSED FEATURE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-28 13:58 UTC by narayanp
Modified: 2011-10-10 11:56 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FEATURE

Description narayanp 2011-09-28 13:58:45 UTC
Step To reproduce:

1. Create a solution.
2. Create a folder with screen name.
3. Go to the project directory on the local system.
4. Add image files in the directory on the local system.
5. Launch MonoDev application.
6. Go to Solution name< Screens folder.

Actual result:
Image files added in the directory from local system is not displaying under the MonoDev application.

Expected Result:
Image files added in the directory from local system should display under the MonoDev application.

Environment:
Monodev 2.8 Beta 3
MonoTouch 4.2.2
Mono Framework 2.10.5
Comment 1 Nat Friedman 2011-09-28 14:20:13 UTC
If I understand correctly, what you are trying to do is not supported.

Image files have to be added to the project using the MonoDevelop interface; they cannot be added via the local filesystem.
Comment 2 Mikayla Hutchinson [MSFT] 2011-09-28 14:32:11 UTC
As Nat says, this is by design. The project only contains explicitly added files.

Note that you can right-click on the solution tree and select "show all files", then the on-disk files will be shown in the solution tree, but greyed out. You can right-click on these files and use the command "include to project" to include them in the project.
Comment 3 Jatin 2011-10-10 11:12:02 UTC
As per the above comments closing this issue.