Bug 11029 - Missing the Bindings for View.SCALE_X and View.SCALE_Y
Summary: Missing the Bindings for View.SCALE_X and View.SCALE_Y
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.6.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Atsushi Eno
URL:
Depends on:
Blocks:
 
Reported: 2013-03-10 22:45 UTC by Tom Opgenorth
Modified: 2014-03-27 11:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Tom Opgenorth 2013-03-10 22:45:23 UTC
Starting with API 14, Android introduced the these two:
  View.SCALE_X - http://developer.android.com/reference/android/view/View.html#SCALE_X
  View.SCALE_Y - http://developer.android.com/reference/android/view/View.html#SCALE_Y

If you create a Xamarin.Android project that targets API level 17 (minimum target is 15), their seems to be no corresponding bindings for these two fields.
Comment 1 Atsushi Eno 2013-03-10 23:34:24 UTC
Looks like this property conflicts with the field.

http://androidapi.xamarin.com/?link=P:Android.Views.View.ScaleX
Comment 2 Atsushi Eno 2013-03-11 07:07:21 UTC
fixed in master [fe4001a]
Comment 3 Udham Singh 2014-03-27 11:15:33 UTC
I have checked this issue on following builds:

Mac OS X 10.9.2
Xamarin Studio : 4.2.3 (build 60)
Xamarin.Android: 4.13.0 (Business Edition)

Screencast: http://screencast.com/t/kxoYITPpUbq

Now this issue is working fine, Hence I am closing this issue.