Bug 11026 - mmap(...PROT_NONE...) failed
Summary: mmap(...PROT_NONE...) failed
Status: RESOLVED DUPLICATE of bug 6216
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-03-10 08:31 UTC by hui
Modified: 2013-04-21 15:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 6216

Description hui 2013-03-10 08:31:56 UTC
mmap(...PROT_NONE...) failed
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_string_alloc (intptr) <0xffffffff>
  at (wrapper alloc) object.Alloc (intptr,int) <0xffffffff>
  at string.Concat (string,string) <0x0007d>
.......

Native stacktrace:

	mono-sgen() [0x49ad15]
	/lib64/libpthread.so.0() [0x339560f500]
	/lib64/libc.so.6(gsignal+0x35) [0x3394e328a5]
	/lib64/libc.so.6(abort+0x175) [0x3394e34085]
	mono-sgen() [0x5f8dbb]
	mono-sgen() [0x5fa1ed]
	mono-sgen() [0x6004bf]
	mono-sgen() [0x5eeda2]
	mono-sgen() [0x5ee433]
	mono-sgen() [0x5ef4e0]
	mono-sgen() [0x5ef760]
	mono-sgen() [0x5f2edd]
	mono-sgen() [0x5f3015]
	mono-sgen() [0x5f3211]
	mono-sgen() [0x5fd8a1]
	mono-sgen(mono_string_new_size+0x58) [0x59dd08]
	[0x41f5c4da]

Thread 1 (process 2861):
#0  0x9560ed2d in ?? ()
Cannot access memory at address 0xde166f40

Code:
MySqlCommand command = connection.CreateCommand();
string commandText = string.Format("insert into TestLog set dataid = {0},createdserverid = {1},timesign = @TIMESIGN,datastate = 1",1,1);
commandText += ",AccountSn = @AccountSn";




Very strange,No reason such a mistake. . .
Comment 1 hui 2013-03-10 08:57:53 UTC
A lot of similar calls:

string += string;

Run continuously for six days, about 6000,000++ calls.Little chance of it.
Comment 2 Zoltan Varga 2013-04-21 15:35:20 UTC

*** This bug has been marked as a duplicate of bug 6216 ***