Bug 10990 - PolicyOptionsPanel crashes hard
Summary: PolicyOptionsPanel crashes hard
Status: RESOLVED DUPLICATE of bug 10513
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-03-08 05:39 UTC by Matthias Mailänder
Modified: 2013-03-09 11:50 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log with MONO_OPTIONS="--debug" (24.15 KB, text/x-log)
2013-03-08 05:48 UTC, Matthias Mailänder
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 10513

Description Matthias Mailänder 2013-03-08 05:39:37 UTC
When I press [Edit] - [User Guidelines] (approximation as I use the German translation, I mean the last button in the menu). This happens all the time on openSUSE 12.2 with KDE 4.10.1 and MonoDevelop 4.0
Comment 1 Matthias Mailänder 2013-03-08 05:40:29 UTC
Mono JIT compiler version 3.0.4 (tarball Sun Feb 24 04:32:46 UTC 2013)
Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  x86
        Disabled:      none
        Misc:          softdebug 
        LLVM:          supported, not enabled.
        GC:            Included Boehm (with typed GC and Parallel Mark)
Comment 2 Matthias Mailänder 2013-03-08 05:46:02 UTC
Crash with the same error message in Settings - Source Code - Naming Conventions / .NET naming guidelines / standard header as well as Settings - Git - commit message style / changelog integration so this might spawn the same broken GUI widget.
Comment 3 Matthias Mailänder 2013-03-08 05:48:01 UTC
Created attachment 3558 [details]
IDE log with MONO_OPTIONS="--debug"
Comment 4 Mikayla Hutchinson [MSFT] 2013-03-08 14:24:02 UTC
Known JIT crash, please upgrade Mono.

*** This bug has been marked as a duplicate of bug 10513 ***
Comment 5 Matthias Mailänder 2013-03-09 11:50:37 UTC
Upgraded to 3.0.6 in https://build.opensuse.org/request/show/158090