Bug 10971 - Code completion UI oddity with custom style
Summary: Code completion UI oddity with custom style
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-03-07 14:00 UTC by Michael James
Modified: 2013-03-07 14:22 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot of issue (104.66 KB, image/jpeg)
2013-03-07 14:00 UTC, Michael James
Details
Custom style (5.88 KB, text/plain)
2013-03-07 14:00 UTC, Michael James
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michael James 2013-03-07 14:00:00 UTC
Created attachment 3551 [details]
screenshot of issue

A customer has reported seeing a blackbar with the code completion UI when using a custom style. 

See attached image and custom style.
Comment 1 Michael James 2013-03-07 14:00:32 UTC
Created attachment 3552 [details]
Custom style
Comment 2 Mike Krüger 2013-03-07 14:22:12 UTC
This bug got fixed (style system changed).

The color was missing from the custom style - I think that caused that. The new style system is way less error prone.