Bug 10851 - Cannot build any projects with a clean installation
Summary: Cannot build any projects with a clean installation
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.8.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-03-03 11:43 UTC by Alan McGovern
Modified: 2013-03-07 04:47 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alan McGovern 2013-03-03 11:43:57 UTC
After a clean installation of my system I got this error when trying to build a new project:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task GenerateJavaStubs: Directory '/Users/alan/Library/Developer/Xamarin/android-sdk-mac_x86/add-ons

The error is becauset he 'add-ons' directory does not exist yet we try to use it. If i create this directory then the build works just fine.
Comment 1 Alan McGovern 2013-03-03 11:44:42 UTC
I just noticed the error was truncated. Here it is again:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task GenerateJavaStubs: Directory '/Users/alan/Library/Developer/Xamarin/android-sdk-mac_x86/add-ons' not found
Comment 2 Jonathan Pryor 2013-03-03 11:58:02 UTC
Fixed in master/5da52a8e.
Comment 3 narayanp 2013-03-07 04:47:03 UTC
Today we have checked this issue using following builds on fresh installation

X.S 4.0 - 1645b898271456799b70944c8b356ed6c5c00fdf
Xamarin.Android - 4.6.1
Mono- 2.10.12 (mono-2-10/823e22f)

We are successfully able to build and run android applications on physical device as well as on emulator.

Changing the status to Verified.