Bug 10773 - _Every_ time i try to quit Xam Studio with cmd + q it gives me an errrr
Summary: _Every_ time i try to quit Xam Studio with cmd + q it gives me an errrr
Status: RESOLVED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0
Hardware: Macintosh Mac OS
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-28 13:19 UTC by bryan costanich
Modified: 2013-11-19 18:16 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Comment 1 Mikayla Hutchinson [MSFT] 2013-02-28 13:24:14 UTC
What mono version?
Comment 2 bryan costanich 2013-02-28 20:46:56 UTC
Mono JIT compiler version 3.0.3 (master/558b532 Mon Jan  7 13:29:00 EST 2013)
Comment 3 Mikayla Hutchinson [MSFT] 2013-03-01 04:02:19 UTC
Xamarin Studio does not run on Mono 3.0.3 because the version of GTK+ is too old.

Can you repro with Mono 3.0.6?
Comment 4 bryan costanich 2013-03-01 14:46:34 UTC
well, it is running.

why isn't it telling me there are updates? i checked for updates and it told me it's up to date.
Comment 5 Mikayla Hutchinson [MSFT] 2013-03-01 15:57:03 UTC
XS is not in the updater yet.

If it's running on Mono 3.0.3, you must be running old beta versions. Please update.
Comment 6 bryan costanich 2013-03-01 16:15:36 UTC
i downloaded the new unified installer and reinstalled, still says mono 3.0.3
Comment 7 Mikayla Hutchinson [MSFT] 2013-03-01 17:50:47 UTC
The installer won't install 2.10.11 over 3.0.3 because the version number is bigger - even though 2.10.11 is newer.

Also, XS won't run at all on Mono 3.0.3 as shipped (it shows a "please update mono" dialog, so you must have some wrench version of Mono.

Please manually install Mono 2.10.11 or 3.0.6.
Comment 8 PJ 2013-11-19 17:05:35 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 9 bryan costanich 2013-11-19 18:16:54 UTC
This no longer repros. It got fixed somewhere along the way.