Bug 10759 - The sample SceneKitViewer crashes throwing exception.
Summary: The sample SceneKitViewer crashes throwing exception.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-28 05:56 UTC by Nischal
Modified: 2013-06-20 11:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Aaron Bockover [MSFT] 2013-05-21 17:08:14 UTC
I'm not able to reproduce this. The scene.dae file is in the app bundle as expected.
Comment 2 Saurabh 2013-05-27 11:56:18 UTC
We are still getting same issue. As soon as application launches it throws exception "System.ArgumentNullException."

Stack Trace: https://gist.github.com/atin360/4eb654c075ebb31bf4cd
XS log: https://gist.github.com/atin360/fe40459330c8f99ab707
Screenshot: http://screencast.com/t/r4tiWYBP4h9

Environment:
Mountain Lion 10.8.1
XS 4.0.8(Build 2)
Mono 2.10.13
Xamarin.mac 1.3.55

App info:
mac-samples-master (1)1c5bc400039a88b3f9850e7dbcce5181e1ccdaca
Comment 3 Saurabh 2013-05-27 12:07:18 UTC
An Update in Comment2,  we have mentioned wrong Mono version, here is the correct info: Mono 2.10.12

Thanks!
Comment 4 Atin 2013-06-20 11:01:05 UTC
Today, We have checked this issue with following builds:

XS 4.0.8
Mono 2.10.12
Xam.mac 1.4.21

Now sample is running successfully, Without throwing any exception. Hence marking this as Verified fixed.