Bug 1074 - Delete option is non-functional.
Summary: Delete option is non-functional.
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8 beta 3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-27 10:03 UTC by Nischal
Modified: 2011-10-10 12:00 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Nischal 2011-09-27 10:03:04 UTC
Steps to Reproduce:
1. Launch the MonoDevelop.
2. Click on "Start New Solution" link.
3. Expand C# by clicking on the + beside it.
4. Select Mono for Android in the left panel.
5. Select Mono for Android Application in the centre panel.
6. Enter name into Name field.
6. Select a location.
7. Click on "Forward" button.
8. Click on OK button on Project Feature pop up.
9. Click on 'View' and then click on Visual Design.
10.Solution sidebar appears at the left panel.
11.Right Click on Solution. 
12.Click on the option "Delete".
13.Observe that nothing happens, i.e the user colud not able to delete the solution. 

Actual Result:
When right click over the Solution and select the option 'Delete', nothing happens, i.e the user colud not able to delete the solution.  

Expected Result: 
When right click over the Solution and select the option 'Delete', it should display a pop-up, in order to confirm whether the user actually wants to delete the solution or not. 

Environment:
Mac 10.6 (Snow Leopard)
Mono Develop 2.8 Beta 3
Comment 1 Alan McGovern 2011-09-28 11:28:47 UTC
I couldn't reproduce the issue. Could you do a screencast which shows the bug?
Comment 2 Saurabh 2011-10-10 06:25:10 UTC
The delete option will not appear for root element in MonoDevelop.This is no longer an issue hence closing this issue.