Bug 10722 - Xamarin.Studio: Does not remember build configurations
Summary: Xamarin.Studio: Does not remember build configurations
Status: VERIFIED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-27 06:52 UTC by Prashant Cholachagudda
Modified: 2013-02-28 18:51 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Steps to reproduce the bug (1.22 MB, application/octet-stream)
2013-02-27 06:52 UTC, Prashant Cholachagudda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Prashant Cholachagudda 2013-02-27 06:52:18 UTC
Created attachment 3497 [details]
Steps to reproduce the bug

Description of Problem:
Xamarin Studio does not remember the build configuration when changed from project options, 
during the build it always uses the configuration it is loaded with.

Steps to reproduce the problem:
1. See attachment

Actual Results:
Does not remember the build configuration

Expected Results:
Should remember the build configuration
Comment 1 Mikayla Hutchinson [MSFT] 2013-02-28 00:24:57 UTC
Changing the configuration in the project options only changes the configuration that the dialog is editing, it does not change the workspace's active configuration. This is consistent with other IDEs such as Visual Studio.

Please reopen if I'm missing something!
Comment 2 Mikayla Hutchinson [MSFT] 2013-02-28 00:25:35 UTC
Love the format of the repro recording BTW, nice and clear :)
Comment 3 Nischal 2013-02-28 03:48:41 UTC
We have verified this issue with the latest builds:

MD 4.0 - 9b07a6655aa75ea1b870feacd2ac7c53b45d3889
MFA 4.6.010121
MT 6.2.1.170

And we have observed that it behaving the way it is mentioned in the comment #1

As Changing the configuration in the project options does not change the configuration of the application, it is simply changing the setting of that particular configuration, for future use.

Hence, closing this issue.
Comment 5 Mikayla Hutchinson [MSFT] 2013-02-28 18:51:08 UTC
Maybe we could do it like VS, i.e. have "Active (configname)" as one of the dropdown options, which would  make it clear that there's distinction between the active and selected configuration.