Bug 10659 - Mono compiler fails on generic type inference from another assembly
Summary: Mono compiler fails on generic type inference from another assembly
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-02-25 16:45 UTC by Paul Ryland
Modified: 2013-02-28 10:44 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test project that reproduces the compile error (674.17 KB, application/x-zip-compressed)
2013-02-25 16:45 UTC, Paul Ryland
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Ryland 2013-02-25 16:45:34 UTC
Created attachment 3479 [details]
Test project that reproduces the compile error

The attached test project reproduces an error where the mono compiler seems to fail to infer the type of a generic parameter (see the comments in the test project). The problem only occurs when the generic methods are in a different assembly. The compile error is not produced if the project is built using VS/.NET.

The compile error produced for the attached test project is:
 error CS1061: Type `T' does not contain a definition for `String' and no extension method `String' of type `T' could be found
Comment 1 Paul Ryland 2013-02-25 16:48:04 UTC
To clarify, the comments in the test project are in Main.cs (line 36)
Comment 2 Marek Safar 2013-02-28 10:44:44 UTC
I cannot reproduce this with Mono 3.x, marking as already fixed