Bug 10656 - Tool window (GTK# designer) in Xamarin Studio does not respect language settings
Summary: Tool window (GTK# designer) in Xamarin Studio does not respect language settings
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: GTK# Designer ()
Version: 4.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-25 15:44 UTC by Patrik Svensson
Modified: 2016-10-18 13:51 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (99.83 KB, image/png)
2013-02-25 15:44 UTC, Patrik Svensson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Patrik Svensson 2013-02-25 15:44:08 UTC
Created attachment 3477 [details]
Screenshot

(I'm not completely sure if I'm reporting this bug on the right component)

I've changed the language to English (system language is Swedish), but the different panels in the toolbox ("Widgets", "Containers" etc.) are still displayed in Swedish ("Widgetar", "Behållare").

Reproduction steps:
-------------------

Not sure how to reproduce if the system language is English, but here's what I did:

1. Installed and started Xamarin Studio (with no prior Xamarin Studio or MonoDevelop install).
2. Changed the "User Interface Language" to "English" in the Language settings panel.
3. Restarted Xamarin Studio.
4. Created new GTK#-project and opened the MainWindow component.

I know that the reproduction steps might be overkill for a thing like this, but I tell myself that it's better with too much information than too little... ;)
Comment 1 Luis Henrique 2014-02-19 10:30:42 UTC
I have the same problem, but my language is in Portuguese Brazil. I've never selected this language and I can't manage to change it to English!
Xamarin Studio simply doesn't care about your options choice!
Comment 2 Mikayla Hutchinson [MSFT] 2014-02-19 12:35:31 UTC
I suspect the toolbox is keeping the localized titles in the toolbox cache. Try deleting %LOCALAPPDATA%\XamarinStudio-4.0\Config\Toolbox.xml
Comment 3 Mohit Kheterpal 2016-01-08 11:00:04 UTC
Could you please try it by deleting "%LOCALAPPDATA%\XamarinStudio-4.0\Config\Toolbox.xml" as mentioned in comment 2 ?

Thanks
Comment 4 iain 2016-10-18 13:51:38 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks