Bug 10611 - When attempting to link to the DotNetOpenAuth library on a MonoTouch project an internal compiler error occurs
Summary: When attempting to link to the DotNetOpenAuth library on a MonoTouch project ...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-02-23 15:41 UTC by Rhys
Modified: 2015-09-03 14:23 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
An example RootViewController exhibiting the issue. This is a standard Xamarin RootViewController from a brand new Master/Detail template, the only additions are those necessary to use WebConsumer. (5.48 KB, application/octet-stream)
2013-02-23 15:41 UTC, Rhys
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rhys 2013-02-23 15:41:29 UTC
Created attachment 3466 [details]
An example RootViewController exhibiting the issue. This is a standard Xamarin RootViewController from a brand new Master/Detail template, the only additions are those necessary to use WebConsumer.

Description of Problem:
When building the project after adding the reference and attempting to make use of the WebConsumer class as part of the OAuth namespace, I receive the error:

Error CS0584: Internal compiler error: Method not found: 'DotNetOpenAuth.OAuth.WebConsumer.ProcessUserAuthorization'.

I've verified that in fact this method DOES exist, so this appears to be a bug in the compiler.

Steps to reproduce the problem:
1. Add the library as a reference
2. Make use of the WebConsumer class in any way
3. Build


Actual Results:
Internal Compiler Error

Expected Results:
Build Succeeded

How often does this happen? 
Every time

Additional Information:

N/A
Comment 1 Marek Safar 2015-09-03 14:23:01 UTC
I could not verify this but this should be fixed in Mono 4.2. Please attach full project if you can still reproduce it