Bug 10517 - Sample 'Fire' giving build errors
Summary: Sample 'Fire' giving build errors
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-21 07:51 UTC by Saurabh
Modified: 2013-09-30 05:53 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 PJ 2013-02-28 13:45:49 UTC
I can only reproduce the build errors without converting the project to Xamarin.Mac format. Once it's converted, it builds just fine.
Comment 2 Saurabh 2013-03-01 08:28:15 UTC
Today we have checked this issue with following builds:

X.S 4.0 - 1c3e943ebec6a7d6e695af9f7a1808ac5bafdb21
Xamarin.Mac: 1.2.25
Mono - 2.10.11 (mono-2-10/2baeee2)

We have checked this issue in both case using MonoMac and using Xamarin.mac. we are getting same build errors in both case. Below is the screencast for the same:
http://screencast.com/t/SkuYPM1F30

App info:
Fire/macSample-1.2

Hence reopening this issue
Comment 3 Saurabh 2013-08-19 12:08:40 UTC
Today we are getting same issue with following builds:

Xamarin.Mac: 1.4.22/ 1.6.9
Version 4.0.11 (build 7)

We are still getting same issue in both case using MonoMac and using Xamarin.mac.
Comment 4 Aaron Bockover [MSFT] 2013-09-26 14:01:40 UTC
This is fixed in git. It will require an updated Xamarin.Mac.
Comment 5 Atin 2013-09-30 05:53:50 UTC
Today, we have checked this issue with:
XS 4.0.13(build 39)
Xamarin.Mac 1.6.19
Mono 3.2.3 ((no/8d3b4b7)
App info: mac-samples-master 324afff14262b9c8661db8242d9a40cf59b8d771

Now this is working fine without any build error. We are able to successfully run this application. 

Hence marking this as Verified Fixed