Bug 10515 - Application 'CoreWLANWirelessManager' crashed while launching.
Summary: Application 'CoreWLANWirelessManager' crashed while launching.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-21 07:27 UTC by Saurabh
Modified: 2013-02-26 03:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Aaron Bockover [MSFT] 2013-02-25 15:00:52 UTC
This crash was because you have no wireless interfaces on your machine (likely running in a VM?). I've updated the sample to not crash and show an alert if no wireless interfaces are available, however this sample really needs to be tested on a machine with wireless interfaces.
Comment 2 Nischal 2013-02-26 03:43:12 UTC
Today we have checked this issue with following builds:

X.S 4.0 -0a40582a1d122994063594ea2ea725960c26b671
Mono 2.10.11(mono-2-10/2baeee2)
Xamarin.Mac 1.2.13

As per comment 1 Application does not crash when system is connected to wireless interface. 
Now we are facing a different issue as after clicking on Refresh button, nothing happens. For the same we have reported a different issue Bug 10676 

Changing the status of this issue to Verified