Bug 10512 - When build the sample CFNetwork using Mono 3.0.4, then 26 build errors are appearing.
Summary: When build the sample CFNetwork using Mono 3.0.4, then 26 build errors are ap...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 2.0.x
Assignee: Oleg Demchenko
URL:
Depends on:
Blocks:
 
Reported: 2013-02-21 06:26 UTC by Saurabh
Modified: 2015-02-24 13:30 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Comment 1 Jatin 2013-02-22 06:58:10 UTC
An update to the above issue:

Today, with the latest builds:
Xamarin.Mac 1.2.2
MD 4.0 - a8219130080af6661ccd827d3ae2589bbfe8c2bb

We have observed that now 26 build errors are appearing.

Below is the gist for the same:
https://gist.github.com/atin360/1929c867900ebc75b01c
Comment 2 Jatin 2013-02-25 05:33:23 UTC
As per PJ's comment in the bug 8798, when we try to debug this sample using the Mono 3.0.4, it gives 26 build errors. Below is the gist for the same:
https://gist.github.com/atin360/6bfd476e42a511eb2164

Below is the build information:

Xamarin.Mac 1.2.8
MD 4.0 - 7e31a9b052b9452b65268a357b4c0b83a848a6f8
Comment 3 narayanp 2013-08-12 03:43:13 UTC
Today we have checked this issue with following builds:

All Mac
X.S 4.0.11(build 7)
Mono 3.2.1-1
X.Mac 1.6.8

Now we are getting 1 build error. This is the gist for the same: https://gist.github.com/saurabh360/d7a8100ac13ab943dde4
Comment 5 Oleg Demchenko 2015-02-24 13:30:55 UTC
It seems that bug was fixed during the process of samples migration, app works fine for me in both master and classic-api branches.