Bug 10510 - After updating mac icon, it does not appear in Doc after debug/run application.
Summary: After updating mac icon, it does not appear in Doc after debug/run application.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-21 06:16 UTC by Nischal
Modified: 2013-02-27 05:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Aaron Bockover [MSFT] 2013-02-25 15:13:49 UTC
I am unable to reproduce this. Setting the application icon works as I would expect.

I did not see you add a .icns file to the project and your resources directory looks empty (no expander error).

The correct process:

- Add a .icns icon to the project's [blue] Resources folder
- Ensure the added .icns file's Build Action is 'BundleResource' (this should be set for you simply by adding a file to the Resources folder)
- Go to Project Options > Build > Mac OS X Application
- Click the 'App Icon' button
- Select the .icns file under Project Folders > Resources
- Press OK
- Press OK on Project Options
- Build/Run
- Observe application icon is set in OS X dock
Comment 2 Nischal 2013-02-26 05:14:18 UTC
This issue still exists with the latest builds:

XS 4.0 - 0a40582a1d122994063594ea2ea725960c26b671
Xamarin.Mac 1.2.13
Mono 2.10.11 
mac-samples-xammac-1.2 - 0c45256650f1dda76937763af0832237e2ffa4df

As after adding the .icns file to the project when updated the AppIcon through Project options >> Build >> Mac OS X Application >> Summary >> App Icon

Then on debugging the application the icon of the application does not get updated successfully.

Below is the screencast for the same:
http://www.screencast.com/t/S8XXSm5G1KHK

Hence, reopening this issue
Comment 3 PJ 2013-02-26 07:46:13 UTC
Nischal, are you setting the .icns build action to BundleResource?
Comment 4 Jatin 2013-02-26 07:52:55 UTC
Ok

SO after setting the .icns file's Build Action to Bundle Resource, the app icon is getting updated successfully.

Below s the build information:
XS 4.0 - 0a40582a1d122994063594ea2ea725960c26b671
Xamarin.Mac 1.2.13
Mono 2.10.11 
mac-samples-xammac-1.2 - 0c45256650f1dda76937763af0832237e2ffa4df

The issue is not appearing so we can close this issue now.

Thanks
Comment 5 Saurabh 2013-02-27 05:38:48 UTC
As per comment 4 changing the status to verified