Bug 10509 - Sample 'CAQuartzComposition' throwing exception 'SIGSEGV'
Summary: Sample 'CAQuartzComposition' throwing exception 'SIGSEGV'
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 10576 ()
Depends on:
Blocks:
 
Reported: 2013-02-21 05:54 UTC by Saurabh
Modified: 2013-02-27 05:42 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Aaron Bockover [MSFT] 2013-02-25 15:16:40 UTC
On Mountain Lion the application works as expected with a camera. On Lion
without a camera the application works as expected, however on Lion with a
camera I can reproduce the crash.

However the crash is coming from inside OpenGL it seems and not Xamarin.Mac.
This could also be a bug with OpenGL + Lion running inside a virtual machine,
which is often common.
Comment 2 Aaron Bockover [MSFT] 2013-02-25 15:17:00 UTC
*** Bug 10576 has been marked as a duplicate of this bug. ***
Comment 3 Nischal 2013-02-26 05:11:59 UTC
Today, we have verified this issue with the latest builds and samples:

XS 4.0 - 0a40582a1d122994063594ea2ea725960c26b671
Xamarin.Mac 1.2.13
Mono 2.10.11 
mac-samples-xammac-1.2 - 0c45256650f1dda76937763af0832237e2ffa4df

And we have observed that on the physical machines of Mac Lion and Mountain Lion, the application is working fine.

However, on VM the application crashes after sometime.

Not sure whether we can close this issue or not, please look into it.
Comment 4 Saurabh 2013-02-27 05:42:25 UTC
As per comment 3 changing the status to Verified