Bug 10483 - Errors not cleared after Upload to Device
Summary: Errors not cleared after Upload to Device
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Greg Munn
URL:
Depends on:
Blocks:
 
Reported: 2013-02-20 19:48 UTC by Mikayla Hutchinson [MSFT]
Modified: 2015-04-01 17:13 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screen shot, successful build but errors (16.16 KB, image/png)
2013-03-20 20:50 UTC, Brad Robinson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mikayla Hutchinson [MSFT] 2013-02-20 19:48:54 UTC
As reported at http://forums.xamarin.com/discussion/1077/build-errors-not-being-cleared-from-errors-list-after-trying-to-deploy-to-device

"When I press F6 or F5 to debug to build I received build errors. If I correct the change then rebuild the errors go away. However if instead of pressing F5 or F6, I go to "Run > Upload to Device" those two errors appear, and when I click either Cancel, or try to continue deploying, duplicate errors show up in the error list. I can then correct my error, but the build errors remain in my error list, despite the fact that I can now build successfully, and the red exclamation mark remains in the notifications window at the top."
Comment 1 Brad Robinson 2013-03-20 20:50:15 UTC
Created attachment 3672 [details]
Screen shot, successful build but errors

I'm seeing this too... see screenshot, errors not getting cleared at start of build.  Build successful, but errors in status window at top and in source code. Closing file and reopening, errors still there.  Rebuild doesn't clear it either.
Comment 2 Mikayla Hutchinson [MSFT] 2014-05-22 18:34:41 UTC
I cannot reproduce this, if you're still seeing it do you have step-by step reproduction instructions?
Comment 3 Greg Munn 2015-04-01 17:13:32 UTC
This is pretty old, with no repro or further information. Closing for now.