Bug 10473 - MonoDevelop and Xamarin Studio windows omitted from Witch window list
Summary: MonoDevelop and Xamarin Studio windows omitted from Witch window list
Status: RESOLVED DUPLICATE of bug 10256
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 4.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-20 13:37 UTC by Michael Bayne
Modified: 2013-04-04 13:28 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 10256

Description Michael Bayne 2013-02-20 13:37:40 UTC
Description of Problem:
I use an alternative app switched (Witch: http://manytricks.com/witch/) which does a fine job of showing every window in the universe, but for some reason MonoDevelop is missing from its window list. Xamarin Studio is also missing from its window list, which prompted me to report this bug.

I know you guys don't give a damn about some third party window switcher, and certainly don't have to support it, but since every other app in the universe works just fine with Witch, it leads me to believe that you're doing something funny (if not wrong) which causes this issue.

Steps to reproduce the problem:
1. Install Witch
2. Trigger the Window switcher, notice that MonoDevelop/Xamarin Studio's windows are not in the list.


Actual Results:
Windows are missing.

Expected Results:
Windows are not missing.

How often does this happen? 
Every time! Yay for reproducibility.

Additional Information:
N/A
Comment 1 Michael Bayne 2013-03-21 18:08:08 UTC
I don't know what you guys did in the latest release, but it works now. Yay!
Comment 2 Lluis Sanchez 2013-04-04 07:20:00 UTC
Closing.
Comment 3 Mikayla Hutchinson [MSFT] 2013-04-04 13:28:03 UTC

*** This bug has been marked as a duplicate of bug 10256 ***