Bug 10390 - User shown INVALID workflow when they have entitlements on disk created by Visual Studio being run as Administrator
Summary: User shown INVALID workflow when they have entitlements on disk created by Vi...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Activation ()
Version: 1.0.x
Hardware: PC Mac OS
: High major
Target Milestone: 1.1.x
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-02-18 16:18 UTC by GouriKumari
Modified: 2013-03-15 15:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 2 PJ 2013-02-18 20:13:49 UTC
This exact test case may become invalidated by the Unified installer change. We will no longer launch VS as administrator after the install.

Instead, for steps 2 and 3, you can just right click VS2012 and run as administrator.
Comment 3 PJ 2013-02-25 10:43:00 UTC
There are only a few reports of this in the wild from support, but this is the 'Looping activation' bug.

For those affected, it can be very annoying. Dominique let me know if you need any more reproduction help.
Comment 5 PJ 2013-02-26 10:50:49 UTC
Also happens with Android
Comment 6 Dominique Louis 2013-03-05 06:17:42 UTC
Pj I certainly do need more reproduction help. I've run as Admin and I'm not able to reproduce this error.
Comment 7 Dominique Louis 2013-03-05 13:59:28 UTC
This commit and bump https://github.com/xamarin/XamarinVS/commit/f952c79a04fd2ddcc450f9ef3a10ddffe180d812 

Should ensure the Entitlements file given "Everyone" access. Which will then stopp the looping.
Comment 8 Dominique Louis 2013-03-11 09:00:56 UTC
PJ : Lluis found that the above fix worked on English Windows, but not Spanish Windows.

I have now put in a fix as part of this commit, bump
https://github.com/xamarin/XamarinVS/commit/06c16e16dc9b69262c378992556f15e159d80a82

That works on both English and non-English Windows OSes.


D.
Comment 9 Atin 2013-03-15 15:19:07 UTC
Today we have verified this issue with latest build:
MTVS 1.1.177
MT 6.2.199
MFA 4.6.01072
VS 2010/2012
Win7 and Win8

Now, this issue doesn't exist. We open the VS as open as Administrative. We are successfully able to open and create project under VS. We are not seeing any trigger workflow.

Hence, Changing the status to Verified.