Bug 10352 - Breakpoint only hit if it is set before starting the program
Summary: Breakpoint only hit if it is set before starting the program
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-02-17 11:17 UTC by Andres G. Aragoneses
Modified: 2013-12-05 18:34 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Andres G. Aragoneses 2013-02-17 11:17:06 UTC
I've sometimes hit this bug in the past, but this time I got an exact testcase which I think anyone can reproduce:

1. Clone banshee master branch in bugzilla (git.gnome.org/banshee.git).
2. Run ./autogen.sh and make
3. Open banshee.sln in MonoDevelop.
4. Right-click in the solution pad on the root element, choose: "Start Debugging Item".
5. For the sake of this test, let's create a folder ~/MusicTest/ and copy there a MP3 file, configure the running banshee to set the default folder of Music Library to be pointing to this new folder.
6. Set the following breakpoints:
  a) RescanPipeline.cs line 176: if (!DatabaseImportManager.IsWhiteListedFile (file_path)) {
  b) QueuePipelineElement.cs line 153: EnqueueDownstream (ProcessItem (item));
7. Click on the menu command "Tools -> Rescan Music Library".

Current results: breakpoint (b) is hit, breakpoint (a) is not hit.
Expected results: both breakpoints should be hit.

Notice: if you set the breakpoints *before* running command "Start Debugging Item", then both breakpoints are hit as well.
Comment 1 Andres G. Aragoneses 2013-02-17 11:18:42 UTC
Typo: s/in bugzilla/from gnome/

( Don't know what I was thinking ^-^ )
Comment 2 Jeffrey Stedfast 2013-03-29 13:41:49 UTC
This seems to work for me when launching Banshee and then setting the breakpoint in (a) before going to Tools -> Rescan Music Library
Comment 3 PJ 2013-11-19 17:04:07 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:34:09 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.