Bug 10332 - code tooltip appears on wrong monitor the first time
Summary: code tooltip appears on wrong monitor the first time
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0
Hardware: PC Mac OS
: Low normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-02-15 17:37 UTC by Jeffrey Stedfast
Modified: 2016-11-05 07:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jeffrey Stedfast 2013-02-15 17:37:17 UTC
A user on the forums reported:

==============================
Hello guys,

I am using XS on my MacBook Pro with an external monitor. The dock is located on the second monitor which is located right to the Mac. If I hover over some code the tooltip seems to be created in the top left corner of the first screen (Mac) as a small rectangle. After that it is moved to the mouse location. The effect is quite noticable and a bit irritating.
==============================
Comment 1 Mikayla Hutchinson [MSFT] 2013-02-26 17:17:20 UTC
This looks like it's because the TooltipInformationWindow does ShowAll in its ctor. It shouldn't be shown until it's moved to the correct location.
Comment 2 Marius Ungureanu 2016-11-05 07:06:39 UTC
The tooltip window is no longer shown in the constructor, and appears on the right screen for me. Marking as resolved.