Bug 10288 - [Xactware] XS is slow to open and load a solution
Summary: [Xactware] XS is slow to open and load a solution
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 4.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2013-02-13 20:01 UTC by Stephen Shaw
Modified: 2017-06-27 16:27 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 10288 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Stephen Shaw 2013-02-13 20:01:04 UTC
Opening a large solution takes time to load. Once its loaded it takes a bit before XS is usable.

This is on an Android solution w/ 50 projects. We also have an iOS solution that is roughly the exact same size both number of project and lines of code. It seems like our Android solution takes longer to be fully loaded than our iOS solution does.
Comment 1 Danish Akhtar 2015-11-20 01:47:24 UTC
Hi Stephen,

Could you please provide your solution and xamarin builds info via XS->About XS->Show Details? So that we can reproduce this issue at our end. 

Also provide XS logs via XS->Help->open log directory->ide logs

Thanks
Comment 2 Kirill Osenkov 2017-05-15 22:21:56 UTC
I think this falls into the general pit of Performance and Profiling. Giving it to Marius for visibility, but I think we can just close it as "Opening large solutions is slow. We know. We should keep profiling and fixing."
Comment 6 Marius Ungureanu 2017-06-27 16:27:58 UTC
There is ongoing work on improving load performance of the solution.