Bug 1005 - When using multi-monitor setup MD always starts at wrong monitor
Summary: When using multi-monitor setup MD always starts at wrong monitor
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: unspecified
Hardware: PC Linux
: Low normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-22 12:50 UTC by Marek Safar
Modified: 2016-12-14 18:48 UTC (History)
5 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2011-09-22 12:50:35 UTC
Most apps start at the monitor where the app is launched or the monitor where the app was used last time but MD always start at monitor 1 (wrong one in my case)
Comment 1 Marek Safar 2011-10-11 14:03:12 UTC
Also when double clicking on top menu to resize MD it gets wrong size.

My setup is little unusual where each monitor has different resolution and monitor 2 is set as a primary display
Comment 2 Jeffrey Stedfast 2011-11-15 15:52:14 UTC
Michael: is this something that might be a gtk bug? I have no idea how this code works.
Comment 3 Mikayla Hutchinson [MSFT] 2011-11-16 09:58:21 UTC
This might be because MD tries to restore its size and position at startup on some platforms. If not, it might just be the window manager (whichever of the 1000 Linux Windows managers it is).
Comment 4 Marius Ungureanu 2013-11-23 10:19:46 UTC
This is an issue on Windows too. Splash screen appears on the right monitor, but MD doesn't start on the right one.
Comment 5 Greg Munn 2016-12-14 18:48:47 UTC
I'm pretty sure this is resolved. XS starts on the correct monitor all the time for me (last couple of years).