Bug 10004 - AppDomain.GetAssemblies() should not change the order
Summary: AppDomain.GetAssemblies() should not change the order
Status: VERIFIED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-02-03 12:16 UTC by Andres G. Aragoneses
Modified: 2013-02-04 14:21 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Andres G. Aragoneses 2013-02-03 12:16:35 UTC
If you use Nancy [1] webframework and are a firm believer of unit testing, it's very probable that you end up using Nancy.Testing [2] library, which embeds the TinyIoC [3] container.

This works well in Mono.

However, if, for creating stubs/mocks of collaborators in your unit tests, you decide to use any Castle.DynamicProxy [4] based library, such as Rhino.Mocks [5], then you have very high chances of running into exceptions like TinyIoCResolutionException when running your tests on Mono (but not MS.NET).

I've tracked this down to a subtle bug in System.Reflection.Emit when emitting dynamic assemblies. Pull request coming in a few minutes, with a fix and a unit test.

[1] http://nancyfx.org/
[2] http://nuget.org/packages/Nancy.Testing
[3] https://github.com/grumpydev/TinyIoC
[4] https://github.com/castleproject/Castle.DynamicProxy-READONLY
[5] https://github.com/ayende/rhino-mocks
Comment 1 Andres G. Aragoneses 2013-02-03 14:15:11 UTC
https://github.com/mono/mono/pull/543
Comment 2 Andres G. Aragoneses 2013-02-04 13:49:48 UTC
PR was merged.
Comment 3 Rodrigo Kumpera 2013-02-04 13:53:20 UTC
Pulled and fixed an additional issue.

Thanks for the patch.
Comment 4 Andres G. Aragoneses 2013-02-04 14:21:34 UTC
Thanks for your review & merge & addition!