Bug 10 - btouch should use its own generated messaging methods instead of the ones in monotouch.dll
Summary: btouch should use its own generated messaging methods instead of the ones in ...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 1.0
Hardware: Macintosh Mac OS
: Normal enhancement
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-07-18 08:31 UTC by Eduardo Scoz
Modified: 2014-05-13 07:19 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Eduardo Scoz 2011-07-18 08:31:54 UTC
MonoTouch can compile other apps here correctly here, but one app that used to work just fine last time I opened it a couple of weeks ago seems to be having problems now. iOS dev tools and MonoTouch were reinstalled during this time, and project had no code changes. Using iOS 4.3. Beta iOS tools are installed, but in a different directory.

If the issue is somehow my fault, I would suggest to at least enhance the error message so it's easier to figure it out.

Here's the log:

Compiling to native code
/Developer/MonoTouch/usr/bin/mtouch -v --nomanifest --nosign -sim "/Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.app" "-r=/Users/escoz/projects/clubtix/MonoTouch.Dialog/bin/iPhoneSimulator/Release/MonoTouch.Dialog.dll" "-r=/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" "-r=/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" "-r=/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" "-r=/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" "-r=/Users/escoz/projects/clubtix/Linea/LineaSDK.dll" "-r=/Developer/MonoTouch/usr/lib/mono/2.1/System.Json.dll" -linksdkonly "-sdk=4.3" -nosymbolstrip -aot="iphone-abi" -v -v -v -gcc_flags "-L/Users/escoz/projects/clubtix/ClubTix -lLineaSDK -framework CoreGraphics -ObjC" "/Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.exe"
Framework is: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
Copied /Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.exe to /Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.app/ClubTix.exe
Linking SDK only for assembly /Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.exe into /Users/escoz/projects/clubtix/ClubTix/bin/iPhoneSimulator/Release/ClubTix.app
Could not link assemblies: Mono.Linker.ResolutionException: Can not resolve reference: System.Void MonoTouch.ObjCRuntime.Messaging::void_objc_msgSend_int_Boolean(System.IntPtr,System.IntPtr,System.Int32,System.Boolean)
  at Mono.Linker.Steps.MarkStep.ResolveMethodDefinition (Mono.Cecil.MethodReference method) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.MarkMethod (Mono.Cecil.MethodReference reference) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.MarkInstruction (Mono.Cecil.Cil.Instruction instruction) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.MarkMethodBody (Mono.Cecil.Cil.MethodBody body) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.ProcessMethod (Mono.Cecil.MethodDefinition method) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.ProcessQueue () [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.Process () [0x00000] in <filename unknown>:0 
  at Mono.Linker.Steps.MarkStep.Process (Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0 
  at Mono.Linker.Pipeline.Process (Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0 
  at MonoTouch.Tuner.Linker.Run (Mono.Linker.Pipeline pipeline, Mono.Linker.LinkContext context) [0x00000] in <filename unknown>:0
Comment 1 Eduardo Scoz 2011-07-18 09:13:57 UTC
Regenerating bindings for a custom library against the new version of MonoTouch worked. I still think these error messages should be enhanced, but this is not a breaking issue anymore.
Comment 2 Sebastien Pouliot 2011-07-18 11:19:03 UTC
This is something we see in building MT itself. It seems the generator has mixed 'bool' and 'Boolean' and that results in errors.
Comment 3 Sebastien Pouliot 2011-07-18 16:01:29 UTC
This looks related to the following commit:
https://github.com/mono/maccore/commit/2008d9fd84b28e744321d71104680487155b9fa5

My guess this only affects code moving from 3.x to 4.0 and only if the bindings are not rebuilt.
Comment 4 Miguel de Icaza [MSFT] 2011-07-22 13:58:38 UTC
The problem that we have is that as time goes by, some of the Messaging methods are added and removed from the core library based on what methods the internal runtime needs.

And third party libraries, when built, reference existing method invocation from Messaging.   What we probably should do is for third party libraries, never consume the monotouch.dll Messaging methods, but instead use its own generated methods, that is the only way that dependency will be fixed.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2014-05-13 07:19:59 UTC
This will be fixed in Xamarin.iOS 7.4